summaryrefslogtreecommitdiff
path: root/src/journal-remote/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-27 21:13:08 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-05-02 16:29:11 -0400
commit2c201c2140f9a75f3698e988880f00f8d0492315 (patch)
tree28f9835b7720692a60dda9b88a598994a03b396c /src/journal-remote/meson.build
parent829257d135c496bd5d2770036c449445f77e0abc (diff)
downloadsystemd-2c201c2140f9a75f3698e988880f00f8d0492315.tar.gz
meson: use booleans for conf.set and drop unecessary conditionals
Using conf.set() with a boolean argument does the right thing: either #ifdef or #undef. This means that conf.set can be used unconditionally. Previously I used '1' as the placeholder value, and that needs to be changed to 'true' for consistency (under meson 1 cannot be used in boolean context). All checks need to be adjusted.
Diffstat (limited to 'src/journal-remote/meson.build')
-rw-r--r--src/journal-remote/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/journal-remote/meson.build b/src/journal-remote/meson.build
index 072fa14548..d266b34e65 100644
--- a/src/journal-remote/meson.build
+++ b/src/journal-remote/meson.build
@@ -21,7 +21,7 @@ systemd_journal_gatewayd_sources = files('''
microhttpd-util.c
'''.split())
-if conf.get('ENABLE_REMOTE', 0) == 1 and conf.get('HAVE_LIBCURL', 0) == 1
+if conf.get('ENABLE_REMOTE', false) and conf.get('HAVE_LIBCURL', false)
journal_upload_conf = configure_file(
input : 'journal-upload.conf.in',
output : 'journal-upload.conf',
@@ -30,7 +30,7 @@ if conf.get('ENABLE_REMOTE', 0) == 1 and conf.get('HAVE_LIBCURL', 0) == 1
install_dir : pkgsysconfdir)
endif
-if conf.get('ENABLE_REMOTE', 0) == 1 and conf.get('HAVE_MICROHTTPD', 0) == 1
+if conf.get('ENABLE_REMOTE', false) and conf.get('HAVE_MICROHTTPD', false)
journal_remote_conf = configure_file(
input : 'journal-remote.conf.in',
output : 'journal-remote.conf',