summaryrefslogtreecommitdiff
path: root/src/journal-remote/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-16 13:30:37 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-31 13:04:18 +0200
commit63e2ebcdaa424e7ddf107312ed02edb176e2bb9f (patch)
treeb155dae46537dfe9a44a9682982ad8bee30eba63 /src/journal-remote/meson.build
parent40c10d3f0055ae08dd2857aecda12ce111a5ed89 (diff)
downloadsystemd-63e2ebcdaa424e7ddf107312ed02edb176e2bb9f.tar.gz
fuzz-journal-remote: allow fuzzer to be built without µhttpd
journal-remote still requires µhttpd, but things are easier if the fuzzer can be built without.
Diffstat (limited to 'src/journal-remote/meson.build')
-rw-r--r--src/journal-remote/meson.build25
1 files changed, 17 insertions, 8 deletions
diff --git a/src/journal-remote/meson.build b/src/journal-remote/meson.build
index 99b9003f3b..940153c5fc 100644
--- a/src/journal-remote/meson.build
+++ b/src/journal-remote/meson.build
@@ -8,16 +8,25 @@ systemd_journal_upload_sources = files('''
journal-upload-journal.c
'''.split())
+libsystemd_journal_remote_sources = files('''
+ journal-remote-parse.h
+ journal-remote-parse.c
+ journal-remote-write.h
+ journal-remote-write.c
+ journal-remote.h
+ journal-remote.c
+'''.split())
+
+if conf.get('HAVE_MICROHTTPD') == 1
+ libsystemd_journal_remote_sources += files('''
+ microhttpd-util.h
+ microhttpd-util.c
+'''.split())
+endif
+
libsystemd_journal_remote = static_library(
'systemd-journal-remote',
- 'journal-remote-parse.h',
- 'journal-remote-parse.c',
- 'journal-remote-write.h',
- 'journal-remote-write.c',
- 'journal-remote.h',
- 'journal-remote.c',
- 'microhttpd-util.h',
- 'microhttpd-util.c',
+ libsystemd_journal_remote_sources,
include_directories : includes,
dependencies : [threads,
libmicrohttpd,