summaryrefslogtreecommitdiff
path: root/src/journal-remote/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-16 10:21:58 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-31 13:04:18 +0200
commitc064d8db402de0c0d609aabcfc722750856a1f01 (patch)
tree8b0b9345e8e706702e8c354d5f828e011eb2b85a /src/journal-remote/meson.build
parent5d889c1365de385e6adbdea96a57f9df00c23013 (diff)
downloadsystemd-c064d8db402de0c0d609aabcfc722750856a1f01.tar.gz
journal-remote: split out µhttpd support and main() into a separate file
This is in preparation to reusing the RemoteServer in other concepts. I tried to keep changes to minimum: - arg_* global variables are now passed as state in RemoteServer - exported functions get the "journal_remote_" prefix - some variables are renamed In particular, there is an ugly global RemoveServer* variable. It was originally added because µhttpd did not allow state to be passed to the callbacks. I'm not sure if this has been remediated in µhttpd, but either way, this is not changed here, the global variable is only renamed for clarity.
Diffstat (limited to 'src/journal-remote/meson.build')
-rw-r--r--src/journal-remote/meson.build27
1 files changed, 19 insertions, 8 deletions
diff --git a/src/journal-remote/meson.build b/src/journal-remote/meson.build
index c5a3dff635..99b9003f3b 100644
--- a/src/journal-remote/meson.build
+++ b/src/journal-remote/meson.build
@@ -8,15 +8,26 @@ systemd_journal_upload_sources = files('''
journal-upload-journal.c
'''.split())
+libsystemd_journal_remote = static_library(
+ 'systemd-journal-remote',
+ 'journal-remote-parse.h',
+ 'journal-remote-parse.c',
+ 'journal-remote-write.h',
+ 'journal-remote-write.c',
+ 'journal-remote.h',
+ 'journal-remote.c',
+ 'microhttpd-util.h',
+ 'microhttpd-util.c',
+ include_directories : includes,
+ dependencies : [threads,
+ libmicrohttpd,
+ libgnutls,
+ libxz,
+ liblz4],
+ install : false)
+
systemd_journal_remote_sources = files('''
- journal-remote-parse.h
- journal-remote-parse.c
- journal-remote-write.h
- journal-remote-write.c
- journal-remote.h
- journal-remote.c
- microhttpd-util.h
- microhttpd-util.c
+ journal-remote-main.c
'''.split())
systemd_journal_gatewayd_sources = files('''