summaryrefslogtreecommitdiff
path: root/src/kernel-install/meson.build
diff options
context:
space:
mode:
authorJoerg Behrmann <behrmann@physik.fu-berlin.de>2022-11-23 16:43:19 +0100
committerLennart Poettering <lennart@poettering.net>2022-11-29 11:33:27 +0100
commit0ccfd3564b2532a4da6526a9e030362c4a142b77 (patch)
treebfc4c7e68d3782fd976e818652c0a000f5f6c5fe /src/kernel-install/meson.build
parent87a7084b3520cef2f54db355d76ebb538202e907 (diff)
downloadsystemd-0ccfd3564b2532a4da6526a9e030362c4a142b77.tar.gz
kernel-install: Add uki layout
Currently the kernel-install man page only documents the bls layout for use with the boot loader spec type #1. 90-loaderentry.install uses this layout to generate loader entries and copy the kernel image and initrd to $BOOT. This commit documents a second layout "uki" and adds 90-uki-copy.install, which copies a UKI "uki.efi" from the staging area or any file with the .efi extension given on the command line to $BOOT/EFI/Linux/$ENTRY_TOKEN-$KERNEl_VERSION(+$TRIES).efi This allows for both locally generated and distro-provided UKIs to be handled by kernel-install.
Diffstat (limited to 'src/kernel-install/meson.build')
-rw-r--r--src/kernel-install/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/kernel-install/meson.build b/src/kernel-install/meson.build
index e5cfdb824c..b0b6c27ede 100644
--- a/src/kernel-install/meson.build
+++ b/src/kernel-install/meson.build
@@ -12,6 +12,8 @@ loaderentry_install = custom_target(
install_mode : 'rwxr-xr-x',
install_dir : kernelinstalldir)
+uki_copy_install = files('90-uki-copy.install')
+
if want_kernel_install
install_data('50-depmod.install',
install_mode : 'rwxr-xr-x',