summaryrefslogtreecommitdiff
path: root/src/libsystemd/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2021-01-05 15:03:39 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2021-01-19 07:06:32 +0900
commit024e9084c1eee8d5485bbdf7c80291eb0fed692e (patch)
treee2e200a112bdcfaea5506b4c30432c98cf86ce8f /src/libsystemd/meson.build
parent40dbce36df1d70e32800545b06d5e08996f8e33f (diff)
downloadsystemd-024e9084c1eee8d5485bbdf7c80291eb0fed692e.tar.gz
meson: move several definitions related libsystemd to src/libsystemd/meson.build
Diffstat (limited to 'src/libsystemd/meson.build')
-rw-r--r--src/libsystemd/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/libsystemd/meson.build b/src/libsystemd/meson.build
index 3843c2aae0..b8a9bbe222 100644
--- a/src/libsystemd/meson.build
+++ b/src/libsystemd/meson.build
@@ -170,7 +170,11 @@ libsystemd_static = static_library(
librt],
c_args : libsystemd_c_args)
-libsystemd_sym = 'src/libsystemd/libsystemd.sym'
+libsystemd_sym = files('libsystemd.sym')
+libsystemd_sym_path = join_paths(meson.current_source_dir(), 'libsystemd.sym')
+
+static_libsystemd = get_option('static-libsystemd')
+static_libsystemd_pic = static_libsystemd == 'true' or static_libsystemd == 'pic'
configure_file(
input : 'libsystemd.pc.in',