summaryrefslogtreecommitdiff
path: root/src/libsystemd/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2022-04-20 15:35:28 +0200
committerLennart Poettering <lennart@poettering.net>2022-04-26 21:45:03 +0200
commitacc50c92ebdaac856f29073b6b794c4a1ab40341 (patch)
tree66f8cf89ee80703044a116d87d593f57d051d4f1 /src/libsystemd/meson.build
parent6ed7b6977f5a7d0b1fa3c892dc600dcf4e76b05c (diff)
downloadsystemd-acc50c92ebdaac856f29073b6b794c4a1ab40341.tar.gz
basic: move compress.[ch] → src/basic/
The compression helpers are used both in journal code and in coredump code, and there's a good chance we'll use them later for other stuff. Let's hence move them into src/basic/, to make them a proper internal API we can use from everywhere where that's desirable. (pstore might be a candidate, for example) No real code changes, just some moving around, build system rearrangements, and stripping of journal-def.h inclusion.
Diffstat (limited to 'src/libsystemd/meson.build')
-rw-r--r--src/libsystemd/meson.build18
1 files changed, 2 insertions, 16 deletions
diff --git a/src/libsystemd/meson.build b/src/libsystemd/meson.build
index a86b8f896b..fa71a5dd11 100644
--- a/src/libsystemd/meson.build
+++ b/src/libsystemd/meson.build
@@ -5,8 +5,6 @@ sd_journal_sources = files(
'sd-journal/audit-type.h',
'sd-journal/catalog.c',
'sd-journal/catalog.h',
- 'sd-journal/compress.c',
- 'sd-journal/compress.h',
'sd-journal/journal-def.h',
'sd-journal/journal-file.c',
'sd-journal/journal-file.h',
@@ -171,7 +169,8 @@ libsystemd_static = static_library(
libsystemd_sources,
include_directories : libsystemd_includes,
c_args : libsystemd_c_args,
- link_with : libbasic,
+ link_with : [libbasic,
+ libbasic_compress],
dependencies : [threads,
librt],
build_by_default : false)
@@ -206,19 +205,6 @@ tests += [
[files('sd-journal/test-catalog.c')],
- [files('sd-journal/test-compress.c'),
- [],
- [liblz4,
- libzstd,
- libxz]],
-
- [files('sd-journal/test-compress-benchmark.c'),
- [],
- [liblz4,
- libzstd,
- libxz],
- [], '', 'timeout=90'],
-
[files('sd-journal/test-audit-type.c')],
]