summaryrefslogtreecommitdiff
path: root/src/libsystemd/meson.build
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@microsoft.com>2021-09-30 11:01:45 +0100
committerLuca Boccassi <luca.boccassi@microsoft.com>2021-10-08 13:11:00 +0100
commitec4afb4606e2b1ea44b0f32778a51c2a8be7eadd (patch)
tree9f64833e32716672694fd2bc37f7b63ae41b1c89 /src/libsystemd/meson.build
parent8d39bff4e36ee3996c5b087ee62ae0d33a82c837 (diff)
downloadsystemd-ec4afb4606e2b1ea44b0f32778a51c2a8be7eadd.tar.gz
libsystemd/sd-id128: use only internal hmac, remove khash/OpenSSL support
Using OpenSSL brings in an additional dependency for all users of libsystemd.so even though it's just one API that makes use of it. The khash implementation is awkward as it requires context switches and computation inside the kernel, thus leaving the process. Remove both from libsystemd.so, and use exclusively the internal hmac fallback. While this is not optimized, the sd-id128 API is not used in performance-critical contexts where hardware acceleration would make a noticeable difference.
Diffstat (limited to 'src/libsystemd/meson.build')
-rw-r--r--src/libsystemd/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/libsystemd/meson.build b/src/libsystemd/meson.build
index 8ec871f6a4..02b2cd64b2 100644
--- a/src/libsystemd/meson.build
+++ b/src/libsystemd/meson.build
@@ -170,8 +170,7 @@ libsystemd_static = static_library(
include_directories : libsystemd_includes,
link_with : libbasic,
dependencies : [threads,
- librt,
- libopenssl],
+ librt],
c_args : libsystemd_c_args)
libsystemd_sym = files('libsystemd.sym')