summaryrefslogtreecommitdiff
path: root/src/libudev/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-19 11:35:01 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-21 17:01:02 +0100
commit37e4d7a8553c6f43217950fa428ac270378c20b0 (patch)
tree0978b8620aa55c2533d5b82e0454f5f6f32ef2c5 /src/libudev/meson.build
parentdb7d1dcae69d95583bfb275bc6895a0b3a5db983 (diff)
downloadsystemd-37e4d7a8553c6f43217950fa428ac270378c20b0.tar.gz
meson: rename libsystemd_internal to libsystem_static
We already use the "_static" suffix for libshared_static ("shared" is the name of the library, "static" is the format) and other libs, so let's rename for consistency. Also change libsystemd_static_sources to libsystemd_sources, since the same list is used for both and shorter is better.
Diffstat (limited to 'src/libudev/meson.build')
-rw-r--r--src/libudev/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libudev/meson.build b/src/libudev/meson.build
index 30d6721b60..09cf762c27 100644
--- a/src/libudev/meson.build
+++ b/src/libudev/meson.build
@@ -41,7 +41,7 @@ libudev = shared_library(
link_args : ['-shared',
'-Wl,--version-script=' + libudev_sym_path],
link_with : [libbasic,
- libsystemd_internal],
+ libsystemd_static],
dependencies : [threads],
link_depends : libudev_sym,
install : true,