summaryrefslogtreecommitdiff
path: root/src/login/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-09 13:11:49 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:26 -0400
commit6b30f2801b426dc8a48412f8fd3789fd84521407 (patch)
tree47e0e27e51dff46490a642aa83772a17e571a4c8 /src/login/meson.build
parent572baca1d4bad218805b71be7f92b2c0385ec1e6 (diff)
downloadsystemd-6b30f2801b426dc8a48412f8fd3789fd84521407.tar.gz
meson: include the library symbol version list in link_depends
This is pretty ugly, because I don't know how to use a single definition for two purposes: - --version-script needs a path relative to the build root - link_depends needs a path relative to source root Also, link_depends does not accept files() output [https://github.com/mesonbuild/meson/issues/1172], and I don't see a way to go from files() output to a string path that can be used to craft the -Wl arg. Ideally, a single files() result could be used in both places. I'm leaving this as a separate commit for now.
Diffstat (limited to 'src/login/meson.build')
-rw-r--r--src/login/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/login/meson.build b/src/login/meson.build
index 5c957063eb..75b8498862 100644
--- a/src/login/meson.build
+++ b/src/login/meson.build
@@ -65,7 +65,7 @@ if conf.get('ENABLE_LOGIND', 0) == 1
install_data(logind_conf,
install_dir : pkgsysconfdir)
- pam_systemd_sym = meson.current_source_dir() + '/pam_systemd.sym'
+ pam_systemd_sym = 'src/login/pam_systemd.sym'
pam_systemd_c = files('pam_systemd.c')
install_data('org.freedesktop.login1.conf',