summaryrefslogtreecommitdiff
path: root/src/nspawn/meson.build
diff options
context:
space:
mode:
authorJan Janssen <medhefgo@web.de>2022-01-11 10:21:23 +0100
committerJan Janssen <medhefgo@web.de>2022-01-11 14:15:54 +0100
commite1eeebbb11ca0eca5dfd2ce32a928ee5174ea7ff (patch)
tree315a40545bb4f33d241411346efdebb6574b6030 /src/nspawn/meson.build
parenta1a03fa54bfb45315eefaa49ceb38a21aceafde8 (diff)
downloadsystemd-e1eeebbb11ca0eca5dfd2ce32a928ee5174ea7ff.tar.gz
meson: Use files() for tests
Not having to provide the full path in the source tree is much nicer and the produced lists can also be used anywhere in the source tree.
Diffstat (limited to 'src/nspawn/meson.build')
-rw-r--r--src/nspawn/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/nspawn/meson.build b/src/nspawn/meson.build
index 11ac404e99..3c1a9c6182 100644
--- a/src/nspawn/meson.build
+++ b/src/nspawn/meson.build
@@ -53,12 +53,12 @@ systemd_nspawn_sources = files('nspawn.c')
############################################################
tests += [
- [['src/nspawn/test-nspawn-tables.c'],
+ [files('test-nspawn-tables.c'),
[libnspawn_core,
libshared],
[libseccomp]],
- [['src/nspawn/test-patch-uid.c'],
+ [files('test-patch-uid.c'),
[libnspawn_core,
libshared],
[libacl],