summaryrefslogtreecommitdiff
path: root/src/resolve/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2020-11-06 13:32:53 +0100
committerLennart Poettering <lennart@poettering.net>2021-02-15 23:14:32 +0100
commit80710ade03d971a8877fde8ce9d42eb2b07f4c47 (patch)
treeda07a32bb5416b4b26a20b5b1a3217a970726f9b /src/resolve/meson.build
parent0886999416a299beeafdf91233eeb52512b1fbb9 (diff)
downloadsystemd-80710ade03d971a8877fde8ce9d42eb2b07f4c47.tar.gz
resolved: instead of closing DNS UDP transaction fds right-away, add them to a socket "graveyard"
The "socket graveyard" shall contain sockets we have sent a question out of, but not received a reply. If we'd close thus sockets immediately when we are not interested anymore, we'd trigger ICMP port unreachable messages once we after all *do* get a reply. Let's avoid that, by leaving the fds open for a bit longer, until a timeout is reached or a reply datagram received. Fixes: #17421
Diffstat (limited to 'src/resolve/meson.build')
-rw-r--r--src/resolve/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/resolve/meson.build b/src/resolve/meson.build
index f34e7ac680..0392ad9874 100644
--- a/src/resolve/meson.build
+++ b/src/resolve/meson.build
@@ -64,6 +64,8 @@ systemd_resolved_sources = files('''
resolved-mdns.h
resolved-resolv-conf.c
resolved-resolv-conf.h
+ resolved-socket-graveyard.c
+ resolved-socket-graveyard.h
resolved-varlink.c
resolved-varlink.h
resolved.c