summaryrefslogtreecommitdiff
path: root/src/rpm/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-01-31 17:30:49 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-02-15 20:49:14 +0100
commit8e5658010dbb929d129539521acb7de3dc6cdf69 (patch)
tree06eba259a0ca8c87040c2a9ccd0f81cab708f86f /src/rpm/meson.build
parent2a9b4bbe3ec3e414dbc02e909c11c9403dba57b1 (diff)
downloadsystemd-8e5658010dbb929d129539521acb7de3dc6cdf69.tar.gz
rpm: pull in the alternative trigger implementation in sh
From https://src.fedoraproject.org/rpms/systemd/blob/master/f/triggers.systemd. In 12dde791d519bc80d5cca4ab6f088763cd481015 scriptlets were converted to lua. This is not only faster and cleaner, but also avoids a nasty dependency loop: rpm implements the lua scripting internally, so we don't need a working shell for the scriplets. This is nice and all, but unfortunately ostree wants to capture scriptlets and execute them at a later time and does not support lua. So in Fedora we ended up with a revert back to a shell-based implementation [1]. At the time I hoped this would only be a temporary workaround, but three years later I think it's fair to assume that this will not happen any time soon. But carrying the upstream lua version and the downstream sh version is error prone. So let's import the other version into our tree too so that they can be kept in sync. [1] https://src.fedoraproject.org/rpms/systemd/c/8e6b39457b3e2660793821e0524855226e33e306
Diffstat (limited to 'src/rpm/meson.build')
-rw-r--r--src/rpm/meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/rpm/meson.build b/src/rpm/meson.build
index 8e5283ff55..d299b18019 100644
--- a/src/rpm/meson.build
+++ b/src/rpm/meson.build
@@ -6,9 +6,13 @@ configure_file(
configuration : substs,
install_dir : rpmmacrosdir == 'no' ? '' : rpmmacrosdir)
+# Those doesn't get installed anywhere, one of them needs to included in the
+# rpm spec file definition.
configure_file(
input : 'triggers.systemd.in',
output : 'triggers.systemd',
configuration : substs)
-# This doesn't get installed anywhere, it needs to included in the rpm spec
-# file definition.
+configure_file(
+ input : 'triggers.systemd.sh.in',
+ output : 'triggers.systemd.sh',
+ configuration : substs)