summaryrefslogtreecommitdiff
path: root/src/shared/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2022-03-23 12:07:06 +0100
committerLennart Poettering <lennart@poettering.net>2022-03-24 15:21:09 +0100
commit7be4b23649c02df33e4292f37ffc8aecf512955a (patch)
tree9418c5876029c06727ea8a2b27d2c066a0532c0c /src/shared/meson.build
parent8fc5c444268be03329164991c3f1cbe9b35a81e9 (diff)
downloadsystemd-7be4b23649c02df33e4292f37ffc8aecf512955a.tar.gz
efi-loader: split efi-api.[ch] from efi-loader.[ch]
Some refactoring: split efi-loader.[ch] in two: isolate the calls that implement out boot loader interface spec, and those which implement access to upstream UEFI firmware features. They are quite different in nature and behaviour, and even semantically it makes to keep these two separate. At the very least because the previous name "efi-loader.[ch]" suggests all was about loader-specific APIs, but much of it is generic uefi stuff... While we are at it, I renamed a bunch of return parameters to follow our usual ret_xyz naming. But besides renaming no real code changes.
Diffstat (limited to 'src/shared/meson.build')
-rw-r--r--src/shared/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/shared/meson.build b/src/shared/meson.build
index 668462f173..4333c9a0a9 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -105,6 +105,8 @@ shared_sources = files(
'dns-domain.h',
'dropin.c',
'dropin.h',
+ 'efi-api.c',
+ 'efi-api.h',
'efi-loader.c',
'efi-loader.h',
'elf-util.c',