summaryrefslogtreecommitdiff
path: root/src/shared/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2023-03-26 16:33:43 +0900
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-03-27 09:51:18 +0200
commit9e43296fd2c4959f045859d248a4e78fcfcceae6 (patch)
tree6eec450ebe932e55056b64ac7a6c4965c1c48ad1 /src/shared/meson.build
parent600362aa11af5af90125aacc8ad7612a5cb80a68 (diff)
downloadsystemd-9e43296fd2c4959f045859d248a4e78fcfcceae6.tar.gz
bootctl: split-out entry token related definitions into boot-entry.[ch]
No functional change, just preparation for later commits. These can be used in kernel-install later. Note, unlike the our usual coding style, the arguments for boot_entry_token_ensure() and parse_boot_entry_token_type() are referenced, updated, and may freed, hence, always pass initialized values. That's why they are not named as 'ret_xyz'.
Diffstat (limited to 'src/shared/meson.build')
-rw-r--r--src/shared/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/shared/meson.build b/src/shared/meson.build
index 9342d25273..cb0697d1b9 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -10,6 +10,7 @@ shared_sources = files(
'bitmap.c',
'blockdev-util.c',
'bond-util.c',
+ 'boot-entry.c',
'boot-timestamps.c',
'bootspec.c',
'bpf-dlopen.c',