summaryrefslogtreecommitdiff
path: root/src/shared/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-12-14 18:03:06 +0100
committerYu Watanabe <watanabe.yu+github@gmail.com>2021-12-25 15:18:50 +0900
commita2b0cd3f5ab3f450e74e2085ad20372a05451c74 (patch)
treef6e693e1f2e21a5d3d830eb7b67735212528eff7 /src/shared/meson.build
parent4287c855893b6a2666fbe0422a1e738c47fa3ef5 (diff)
downloadsystemd-a2b0cd3f5ab3f450e74e2085ad20372a05451c74.tar.gz
meson: allow specifying a custom "tag" for the private shared libaries
We have /usr/lib/systemd/libsystemd-{shared,core}-nnn.so. With this path the 'nnn' part can be changed to something different. The idea is that during a package build this will be set to the package version. This way during in-place upgrades with the same major version both the new and old libraries can cooexit. This should fix the issue when systemd programs are called during package upgrades and fail to exec because the expect different symbols in the library they are linked to. This should fix https://bugzilla.redhat.com/show_bug.cgi?id=1906010.
Diffstat (limited to 'src/shared/meson.build')
-rw-r--r--src/shared/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/shared/meson.build b/src/shared/meson.build
index c2e0233974..f58d623f4a 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -430,7 +430,7 @@ target2 = custom_target(
shared_generated_gperf_headers = [target1, target2]
shared_sources += shared_generated_gperf_headers
-libshared_name = 'systemd-shared-@0@'.format(meson.project_version())
+libshared_name = 'systemd-shared-@0@'.format(shared_lib_tag)
libshared_deps = [threads,
libacl,