summaryrefslogtreecommitdiff
path: root/src/shutdown/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2021-01-01 05:39:55 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2021-01-19 07:04:19 +0900
commit9aeec01e7757c13e5de11b592992a2eaedd67e3d (patch)
treedb7b6b729b54aaf3802cca98e32859466b900aeb /src/shutdown/meson.build
parentbac11cd667cca5545ab90e472dff77baf68d8e0b (diff)
downloadsystemd-9aeec01e7757c13e5de11b592992a2eaedd67e3d.tar.gz
test: move test-umount.c to src/shutdown
Then, we can drop src/shutdown from include directories later.
Diffstat (limited to 'src/shutdown/meson.build')
-rw-r--r--src/shutdown/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/shutdown/meson.build b/src/shutdown/meson.build
index ebf0bed242..78169e0ab6 100644
--- a/src/shutdown/meson.build
+++ b/src/shutdown/meson.build
@@ -3,3 +3,11 @@ systemd_shutdown_sources = files('''
umount.c
umount.h
'''.split())
+
+tests += [
+ [['src/shutdown/test-umount.c',
+ 'src/shutdown/umount.c',
+ 'src/shutdown/umount.h'],
+ [libshared],
+ [libmount]],
+]