summaryrefslogtreecommitdiff
path: root/src/sysext/meson.build
diff options
context:
space:
mode:
authormaanyagoenka <maanyagoenka@microsoft.com>2023-03-29 20:35:18 +0000
committermaanyagoenka <maanyagoenka@microsoft.com>2023-04-05 21:50:04 +0000
commit4da1df42ac419180f8bbfd6bc53a50e02b14af85 (patch)
tree08c230fee28af7765adc2b6af9d2b47c80ad35cf /src/sysext/meson.build
parent30dfe035eb8a6539f5997a798402d2d5225f8567 (diff)
downloadsystemd-4da1df42ac419180f8bbfd6bc53a50e02b14af85.tar.gz
confext: add multi call functionality to sysext
The confext concept is an extension of the existing sysext concept and allows to extend the host's filesystem or a unit's filesystem with signed images that add new files to the /etc/ directory using OverlayFS.
Diffstat (limited to 'src/sysext/meson.build')
-rw-r--r--src/sysext/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/sysext/meson.build b/src/sysext/meson.build
index f159adb8cc..ede953712c 100644
--- a/src/sysext/meson.build
+++ b/src/sysext/meson.build
@@ -1,3 +1,7 @@
# SPDX-License-Identifier: LGPL-2.1-or-later
systemd_sysext_sources = files('sysext.c')
+
+meson.add_install_script(meson_make_symlink,
+ rootbindir / 'systemd-sysext',
+ rootbindir / 'systemd-confext')