summaryrefslogtreecommitdiff
path: root/src/systemd/meson.build
diff options
context:
space:
mode:
authorDavide Cavalca <davide125@tiscali.it>2017-06-15 09:55:13 +0100
committerLennart Poettering <lennart@poettering.net>2017-06-15 10:55:13 +0200
commitec36d052f71888333aaae4ee47f7d1cd2c3c6c0d (patch)
tree667547ed451335fc2c2f6e0d54b9b55b8e84f6b5 /src/systemd/meson.build
parent42d3bf86bb75842602d3712caa2baccd09a1c795 (diff)
downloadsystemd-ec36d052f71888333aaae4ee47f7d1cd2c3c6c0d.tar.gz
meson: only run c++ tests when c++ compiler is available (#6123)
Diffstat (limited to 'src/systemd/meson.build')
-rw-r--r--src/systemd/meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/systemd/meson.build b/src/systemd/meson.build
index 75435acb14..debbd46dff 100644
--- a/src/systemd/meson.build
+++ b/src/systemd/meson.build
@@ -40,8 +40,12 @@ install_headers(
opts = [['c'],
['c', '-ansi'],
- ['c', '-std=iso9899:1990'],
- ['c++']]
+ ['c', '-std=iso9899:1990']]
+
+cxx = find_program('c++', required : false)
+if cxx.found()
+ opts += [['c++']]
+endif
foreach header : _systemd_headers
foreach opt : opts