summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2023-03-03 13:22:27 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2023-03-03 20:39:19 +0900
commitb66b3c409900a77b3da7b366ae5a0179abacea99 (patch)
tree8b7106513ea03e5b1645b4decaba5fa1071947a6 /src/test/meson.build
parentd8f3ad627c9a857d46d442f8ab722c1efab30d5c (diff)
downloadsystemd-b66b3c409900a77b3da7b366ae5a0179abacea99.tar.gz
meson: extend timeout for test-time-util
The test forks so many child processes, and may hit the default time limit on slow environment or running with sanitizers.
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index dc9e95a7bd..ae4c3f13aa 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -156,7 +156,6 @@ simple_tests += files(
'test-strxcpyx.c',
'test-sysctl-util.c',
'test-terminal-util.c',
- 'test-time-util.c',
'test-tmpfile-util.c',
'test-tmpfiles.c',
'test-tpm2.c',
@@ -502,6 +501,10 @@ tests += [
],
},
{
+ 'sources' : files('test-time-util.c'),
+ 'timeout' : 120,
+ },
+ {
'sources' : files('test-udev.c'),
'link_with' : [
libshared,