summaryrefslogtreecommitdiff
path: root/test/fuzz/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-10-04 04:52:44 +0900
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-09 11:54:10 +0200
commitf6d783ac3d145f3f3ffc2023d4ad90f76cf7fe34 (patch)
tree756aaa30aa6ee4a72dd92d7132eb4834c500d496 /test/fuzz/meson.build
parentb37469d7d109414fdce9af8cb3331445b95dd6c0 (diff)
downloadsystemd-f6d783ac3d145f3f3ffc2023d4ad90f76cf7fe34.tar.gz
meson: use same compilers to build fuzzers
Diffstat (limited to 'test/fuzz/meson.build')
-rw-r--r--test/fuzz/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/fuzz/meson.build b/test/fuzz/meson.build
index 56d0f69660..b4aadaab2e 100644
--- a/test/fuzz/meson.build
+++ b/test/fuzz/meson.build
@@ -7,7 +7,9 @@ sanitize_address = custom_target(
meson.source_root(),
'@OUTPUT@',
'fuzzers',
- '-Db_lundef=false -Db_sanitize=address'])
+ '-Db_lundef=false -Db_sanitize=address',
+ ' '.join(cc.cmd_array()),
+ ' '.join(meson.get_compiler('cpp').cmd_array())])
sanitizers = [['address', sanitize_address]]