summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorFrantisek Sumsal <frantisek@sumsal.cz>2021-10-20 19:43:34 +0200
committerLuca Boccassi <luca.boccassi@gmail.com>2021-10-20 22:04:45 +0100
commit140557021ad1a3946319fff1a87831eb02d6a1a0 (patch)
treeda77ec72adb8a3d9ffde20dd9e6f6749e5bf50db /test/meson.build
parent0b5fe54ff5c35849316b916bd9dc042a7a2349e1 (diff)
downloadsystemd-140557021ad1a3946319fff1a87831eb02d6a1a0.tar.gz
test: don't install test-network-generator-conversion.sh w/o networkd
otherwise TEST-02 will fail: ``` === Failed test log === --- test-network-generator-conversion.sh begin --- + [[ -n '' ]] + [[ -x /usr/lib/systemd/systemd-network-generator ]] + [[ -x /lib/systemd/systemd-network-generator ]] + exit 1 --- test-network-generator-conversion.sh end --- ``` Before: ``` $ meson build -Dnetworkd=false -Dinstall-tests=true $ ninja -C build $ DESTDIR=$PWD/test-install ninja -C build install $ find test-install/ -name test-network-generator-conversion.sh test-install/usr/lib/systemd/tests/test-network-generator-conversion.sh ``` After: ``` $ find test-install/ -name test-network-generator-conversion.sh <no output> ```
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/test/meson.build b/test/meson.build
index b8335fb50f..a5bfbb7462 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -100,9 +100,12 @@ if install_tests
install_data('run-unit-tests.py',
install_mode : 'rwxr-xr-x',
install_dir : testsdir)
- install_data('test-network-generator-conversion.sh',
- install_mode : 'rwxr-xr-x',
- install_dir : testsdir)
+
+ if conf.get('ENABLE_NETWORKD') == 1
+ install_data('test-network-generator-conversion.sh',
+ install_mode : 'rwxr-xr-x',
+ install_dir : testsdir)
+ endif
endif
############################################################