summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorJan Janssen <medhefgo@web.de>2022-01-11 10:56:22 +0100
committerJan Janssen <medhefgo@web.de>2022-01-11 14:56:30 +0100
commit68a06b3cdfe35ff08092e139033edb4a5189a439 (patch)
tree21f01d35f46f7c22fa0f453a330a4f3d164d1b7a /test/meson.build
parentbbec46c817951225f1e535d3df95b82a114e502a (diff)
downloadsystemd-68a06b3cdfe35ff08092e139033edb4a5189a439.tar.gz
meson: Add check argument to remaining run_command() calls
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/test/meson.build b/test/meson.build
index 8de1043e17..46eab4c1e1 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -166,14 +166,16 @@ endif
if want_tests != 'false' and dmi_arches.contains(host_machine.cpu_family())
udev_dmi_memory_id_test = find_program('udev-dmi-memory-id-test.sh')
- if git.found()
+ if git.found() and fs.exists(project_source_root / '.git')
out = run_command(
env, '-u', 'GIT_WORK_TREE',
git, '--git-dir=@0@/.git'.format(project_source_root),
- 'ls-files', ':/test/dmidecode-dumps/*.bin')
+ 'ls-files', ':/test/dmidecode-dumps/*.bin',
+ check: true)
else
out = run_command(
- sh, '-c', 'ls @0@/test/dmidecode-dumps/*.bin'.format(project_source_root))
+ sh, '-c', 'ls @0@/test/dmidecode-dumps/*.bin'.format(project_source_root),
+ check: true)
endif
foreach p : out.stdout().split()