summaryrefslogtreecommitdiff
path: root/tmpfiles.d/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-08-19 11:50:04 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-08-19 12:08:14 +0200
commit1f9290fcc48d44373174497b5500b028778db6ab (patch)
treec1427bbc88cd5ef219c431364a112f1a547025af /tmpfiles.d/meson.build
parent265c14cd406b87d544f4ecf695dcde2dd5a0c05d (diff)
downloadsystemd-1f9290fcc48d44373174497b5500b028778db6ab.tar.gz
tmpfiles: override permissions of static nodes that need this
Fixes #13350.
Diffstat (limited to 'tmpfiles.d/meson.build')
-rw-r--r--tmpfiles.d/meson.build35
1 files changed, 21 insertions, 14 deletions
diff --git a/tmpfiles.d/meson.build b/tmpfiles.d/meson.build
index f14b4fc6df..e77f46d06b 100644
--- a/tmpfiles.d/meson.build
+++ b/tmpfiles.d/meson.build
@@ -24,26 +24,33 @@ foreach pair : tmpfiles
endif
endforeach
-m4_files = [['etc.conf', ''],
- ['systemd.conf', ''],
- ['var.conf', ''],
- ]
+in_files = ['static-nodes-permissions.conf']
-foreach pair : m4_files
- if not enable_tmpfiles
- # do nothing
- elif pair[1] == '' or conf.get(pair[1]) == 1
+foreach file : in_files
+ gen = configure_file(
+ input : file + '.in',
+ output : file,
+ configuration : substs)
+ if enable_tmpfiles
+ install_data(gen,
+ install_dir : tmpfilesdir)
+ endif
+endforeach
+
+m4_files = ['etc.conf',
+ 'systemd.conf',
+ 'var.conf']
+
+foreach file : m4_files
+ if enable_tmpfiles
custom_target(
- 'tmpfiles.d_' + pair[0],
- input : pair[0] + '.m4',
- output: pair[0],
+ 'tmpfiles.d_' + file,
+ input : file + '.m4',
+ output: file,
command : [meson_apply_m4, config_h, '@INPUT@'],
capture : true,
install : true,
install_dir : tmpfilesdir)
- else
- message('Not installing tmpfiles.d/@0@.m4 because @1@ is @2@'
- .format(pair[0], pair[1], conf.get(pair[1], 0)))
endif
endforeach