summaryrefslogtreecommitdiff
path: root/tmpfiles.d/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-27 21:13:08 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-05-02 16:29:11 -0400
commit2c201c2140f9a75f3698e988880f00f8d0492315 (patch)
tree28f9835b7720692a60dda9b88a598994a03b396c /tmpfiles.d/meson.build
parent829257d135c496bd5d2770036c449445f77e0abc (diff)
downloadsystemd-2c201c2140f9a75f3698e988880f00f8d0492315.tar.gz
meson: use booleans for conf.set and drop unecessary conditionals
Using conf.set() with a boolean argument does the right thing: either #ifdef or #undef. This means that conf.set can be used unconditionally. Previously I used '1' as the placeholder value, and that needs to be changed to 'true' for consistency (under meson 1 cannot be used in boolean context). All checks need to be adjusted.
Diffstat (limited to 'tmpfiles.d/meson.build')
-rw-r--r--tmpfiles.d/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/tmpfiles.d/meson.build b/tmpfiles.d/meson.build
index dfbe04a976..d68d17e956 100644
--- a/tmpfiles.d/meson.build
+++ b/tmpfiles.d/meson.build
@@ -1,4 +1,4 @@
-enable_tmpfiles = conf.get('ENABLE_TMPFILES', 0) == 1
+enable_tmpfiles = conf.get('ENABLE_TMPFILES', false)
tmpfiles = [['home.conf', ''],
['journal-nocow.conf', ''],
@@ -14,7 +14,7 @@ tmpfiles = [['home.conf', ''],
foreach pair : tmpfiles
if not enable_tmpfiles
# do nothing
- elif pair[1] == '' or conf.get(pair[1], 0) == 1
+ elif pair[1] == '' or conf.get(pair[1], false)
install_data(pair[0], install_dir : tmpfilesdir)
else
message('Not installing tmpfiles.d/@0@ because @1@ is @2@'