summaryrefslogtreecommitdiff
path: root/units/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2021-03-26 22:40:40 +0100
committerLennart Poettering <lennart@poettering.net>2021-04-20 18:26:17 +0200
commit29a24ab28e9790680348b1ffab653a321fa49a67 (patch)
tree6bf35850f80c21a86728106ed767e88a72bc4658 /units/meson.build
parentee7561d014d073944779e155271d7042d7ea5572 (diff)
downloadsystemd-29a24ab28e9790680348b1ffab653a321fa49a67.tar.gz
fstab-generator: if usr= is specified, mount it to /sysusr/usr/ first
This changes the fstab-generator to handle mounting of /usr/ a bit differently than before. Instead of immediately mounting the fs to /sysroot/usr/ we'll first mount it to /sysusr/usr/ and then add a separate bind mount that mounts it from /sysusr/usr/ to /sysroot/usr/. This way we can access /usr independently of the root fs, without for waiting to be mounted via the /sysusr/ hierarchy. This is useful for invoking systemd-repart while a root fs doesn't exist yet and for creating it, with partition data read from the /usr/ hierarchy. This introduces a new generic target initrd-usr-fs.target that may be used to generically order services against /sysusr/ to become available.
Diffstat (limited to 'units/meson.build')
-rw-r--r--units/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/units/meson.build b/units/meson.build
index 15463760c6..fe8e95ff91 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -38,6 +38,7 @@ units = [
['initrd-switch-root.service', 'ENABLE_INITRD'],
['initrd-switch-root.target', 'ENABLE_INITRD'],
['initrd-udevadm-cleanup-db.service', 'ENABLE_INITRD'],
+ ['initrd-usr-fs.target', 'ENABLE_INITRD'],
['initrd.target', 'ENABLE_INITRD'],
['kexec.target', ''],
['ldconfig.service', 'ENABLE_LDCONFIG',