summaryrefslogtreecommitdiff
path: root/units/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2017-08-09 22:13:41 +0900
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-08-09 09:13:41 -0400
commit4429c69f8da0c9ea892541a50d5c5f4ac1b42767 (patch)
treeab0d2fe30d403936fe309adc9848c93e1c192bdf /units/meson.build
parentc7f6ca9379279affa8f22d15fa13063491f86a49 (diff)
downloadsystemd-4429c69f8da0c9ea892541a50d5c5f4ac1b42767.tar.gz
units: do not perform m4 if not necessary (#6575)
Diffstat (limited to 'units/meson.build')
-rw-r--r--units/meson.build18
1 files changed, 9 insertions, 9 deletions
diff --git a/units/meson.build b/units/meson.build
index e94add6a6f..1f57988033 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -99,6 +99,8 @@ units = [
'sockets.target.wants/'],
['time-sync.target', ''],
['timers.target', ''],
+ ['tmp.mount', '',
+ 'local-fs.target.wants/'],
['umount.target', ''],
['user.slice', ''],
['var-lib-machines.mount', 'ENABLE_MACHINED',
@@ -161,6 +163,9 @@ in_units = [
'dbus-org.freedesktop.machine1.service'],
['systemd-modules-load.service', 'HAVE_KMOD',
'sysinit.target.wants/'],
+ ['systemd-networkd.service', 'ENABLE_NETWORKD',
+ join_paths(pkgsysconfdir, 'system/dbus-org.freedesktop.network1.service') + ' ' +
+ join_paths(pkgsysconfdir, 'system/multi-user.target.wants/')],
['systemd-networkd-wait-online.service', 'ENABLE_NETWORKD',
join_paths(pkgsysconfdir, 'system/network-online.target.wants/')],
['systemd-nspawn@.service', ''],
@@ -171,6 +176,9 @@ in_units = [
['systemd-reboot.service', ''],
['systemd-remount-fs.service', '',
'local-fs.target.wants/'],
+ ['systemd-resolved.service', 'ENABLE_RESOLVED',
+ join_paths(pkgsysconfdir, 'system/dbus-org.freedesktop.resolve1.service') + ' ' +
+ join_paths(pkgsysconfdir, 'system/multi-user.target.wants/')],
['systemd-rfkill.service', 'ENABLE_RFKILL'],
['systemd-suspend.service', ''],
['systemd-sysctl.service', '',
@@ -201,6 +209,7 @@ in_units = [
'multi-user.target.wants/'],
['systemd-vconsole-setup.service', 'ENABLE_VCONSOLE'],
['systemd-volatile-root.service', ''],
+ ['user@.service', ''],
]
m4_units = [
@@ -208,20 +217,11 @@ m4_units = [
'autovt@.service ' +
join_paths(pkgsysconfdir, 'system/getty.target.wants/getty@tty1.service')],
['serial-getty@.service', ''],
- ['tmp.mount', '',
- 'local-fs.target.wants/'],
]
m4_in_units = [
['console-getty.service', ''],
['container-getty@.service', ''],
- ['systemd-networkd.service', 'ENABLE_NETWORKD',
- join_paths(pkgsysconfdir, 'system/dbus-org.freedesktop.network1.service') + ' ' +
- join_paths(pkgsysconfdir, 'system/multi-user.target.wants/')],
- ['systemd-resolved.service', 'ENABLE_RESOLVED',
- join_paths(pkgsysconfdir, 'system/dbus-org.freedesktop.resolve1.service') + ' ' +
- join_paths(pkgsysconfdir, 'system/multi-user.target.wants/')],
- ['user@.service', ''],
]
foreach tuple : m4_in_units