summaryrefslogtreecommitdiff
path: root/units/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-09 23:55:50 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:27 -0400
commit7b76fce1a5d2590524f713586d2b38dca5224ef0 (patch)
treecfd657e1adde9738643a82591db47ee549b2337b /units/meson.build
parent94e75a54097b32252ef86e9253a288db7529f1ea (diff)
downloadsystemd-7b76fce1a5d2590524f713586d2b38dca5224ef0.tar.gz
meson: create various symlinks
v2: - remove bashisms
Diffstat (limited to 'units/meson.build')
-rw-r--r--units/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/units/meson.build b/units/meson.build
index 957153c0b5..b051c5d3cc 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -307,6 +307,12 @@ foreach tuple : m4_in_units
endif
endforeach
+meson.add_install_script(meson_make_symlink,
+ pkgsysconfdir + '/user',
+ sysconfdir + '/xdg/systemd/user')
+meson.add_install_script(meson_make_symlink,
+ dbussystemservicedir + '/org.freedesktop.systemd1.service',
+ dbussessionservicedir + '/org.freedesktop.systemd1.service')
if conf.get('HAVE_SYSV_COMPAT', 0) == 1
foreach i : [1, 2, 3, 4, 5]
meson.add_install_script('sh', '-c',