summaryrefslogtreecommitdiff
path: root/units/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2022-12-20 17:16:47 +0100
committerLennart Poettering <lennart@poettering.net>2023-01-04 15:18:10 +0100
commit921fc451cb7ce29467c5d87346db2b8bb72fdf18 (patch)
treea5b95a20968323a302482187f834814511ee34a7 /units/meson.build
parent5019b0cb15d788e5e1f3c15eb7cdca6ee18a847c (diff)
downloadsystemd-921fc451cb7ce29467c5d87346db2b8bb72fdf18.tar.gz
units: rename/rework systemd-boot-system-token.service → systemd-boot-random-seed.service
This renames systemd-boot-system-token.service to systemd-boot-random-seed.service and conditions it less strictly. Previously, the job of the service was to write a "system token" EFI variable if it was missing. It called "bootctl --graceful random-seed" for that. With this change we condition it more liberally: instead of calling it only when the "system token" EFI variable isn't set, we call it whenever a boot loader interface compatible boot loader is used. This means, previously it was invoked on the first boot only: now it is invoked at every boot. This doesn#t change the command that is invoked. That's because previously already the "bootctl --graceful random-seed" did two things: set the system token if not set yet *and* refresh the random seed in the ESP. Previousy we put the focus on the former, now we shift the focus to the latter. With this simple change we can replace the logic f913c784ad4c93894fd6cb2590738113dff5a694 added, but from a service that can run much later and doesn't keep the ESP pinned.
Diffstat (limited to 'units/meson.build')
-rw-r--r--units/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/units/meson.build b/units/meson.build
index 25e9209b4d..79e2935a50 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -105,7 +105,7 @@ units = [
['systemd-ask-password-wall.path', '',
'multi-user.target.wants/'],
['systemd-ask-password-wall.service', ''],
- ['systemd-boot-system-token.service', 'HAVE_GNU_EFI',
+ ['systemd-boot-random-seed.service', 'HAVE_GNU_EFI',
'sysinit.target.wants/'],
['systemd-boot-update.service', 'HAVE_GNU_EFI'],
['systemd-coredump.socket', 'ENABLE_COREDUMP',