summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/man/meson.build b/man/meson.build
index f9c4b83dc8..2e3b858f4f 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -70,7 +70,7 @@ foreach tuple : xsltproc.found() ? manpages : []
link = custom_target(
htmlalias,
output : htmlalias,
- command : ['ln', '-fs', html, '@OUTPUT@'])
+ command : [ln, '-fs', html, '@OUTPUT@'])
if want_html
dst = join_paths(docdir, 'html', htmlalias)
cmd = 'ln -fs @0@ $DESTDIR@1@'.format(html, dst)
@@ -148,7 +148,7 @@ foreach tuple : xsltproc.found() ? [['systemd.directives', '7', systemd_directiv
htmlalias,
input : p2,
output : htmlalias,
- command : ['ln', '-fs', html, '@OUTPUT@'])
+ command : [ln, '-fs', html, '@OUTPUT@'])
if want_html
dst = join_paths(docdir, 'html', htmlalias)
cmd = 'ln -fs @0@ $DESTDIR@1@'.format(html, dst)
@@ -176,15 +176,14 @@ man = custom_target(
'man',
output : 'man',
depends : man_pages,
- command : ['echo'])
+ command : [echo])
html = custom_target(
'html',
output : 'html',
depends : html_pages,
- command : ['echo'])
+ command : [echo])
-rsync = find_program('rsync', required : false)
if rsync.found()
run_target(
'doc-sync',