summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build43
1 files changed, 22 insertions, 21 deletions
diff --git a/man/meson.build b/man/meson.build
index 1c1dbd86b7..79d7710d11 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -130,24 +130,25 @@ foreach tuple : [['systemd.directives', '7', systemd_directives_xml],
html_pages += [p2]
endforeach
-man = custom_target('man',
- depends : man_pages,
- output : 'man',
- command : ['echo'])
-
-html = custom_target('html',
- depends : html_pages,
- output : 'html',
- command : ['echo'])
-
-custom_target('doc-sync',
- depends : [man, html],
- output : ['doc-sync'],
- command : ['rsync', '-rlv',
- '--delete-excluded',
- '--include=man',
- '--include=*.html',
- '--exclude=*',
- '--omit-dir-times',
- meson.current_build_dir(),
- get_option('www-target')])
+man = run_target(
+ 'man',
+ depends : man_pages,
+ command : ['echo'])
+
+html = run_target(
+ 'html',
+ depends : html_pages,
+ output : 'html',
+ command : ['echo'])
+
+run_target(
+ 'doc-sync',
+ depends : man_pages + html_pages,
+ command : ['rsync', '-rlv',
+ '--delete-excluded',
+ '--include=man',
+ '--include=*.html',
+ '--exclude=*',
+ '--omit-dir-times',
+ meson.current_build_dir(),
+ get_option('www-target')])