summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build30
1 files changed, 16 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index e607c5af7c..a856bb2f84 100644
--- a/meson.build
+++ b/meson.build
@@ -356,6 +356,7 @@ possible_common_cc_flags = [
'-Werror=format=2',
'-Werror=format-signedness',
'-Werror=implicit-function-declaration',
+ '-Werror=implicit-int',
'-Werror=incompatible-pointer-types',
'-Werror=int-conversion',
'-Werror=overflow',
@@ -1935,6 +1936,21 @@ subdir('src/boot/efi')
############################################################
+pymod = import('python')
+python = pymod.find_installation('python3', required : true, modules : ['jinja2'])
+python_39 = python.language_version().version_compare('>=3.9')
+
+if get_option('ukify') == 'auto'
+ want_ukify = python_39 and conf.get('HAVE_GNU_EFI') == 1
+elif get_option('ukify') == 'true' and (not python_39 or conf.get('HAVE_GNU_EFI') != 1)
+ error('ukify requires Python >= 3.9 and GNU EFI')
+else
+ want_ukify = get_option('ukify') == 'true'
+endif
+conf.set10('ENABLE_UKIFY', want_ukify)
+
+############################################################
+#
generate_gperfs = find_program('tools/generate-gperfs.py')
make_autosuspend_rules_py = find_program('tools/make-autosuspend-rules.py')
make_directive_index_py = find_program('tools/make-directive-index.py')
@@ -1966,20 +1982,6 @@ jinja2_cmdline = [meson_render_jinja2, config_h, version_h]
############################################################
-pymod = import('python')
-python = pymod.find_installation('python3', required : true, modules : ['jinja2'])
-python_39 = python.language_version().version_compare('>=3.9')
-
-if get_option('ukify') == 'auto'
- want_ukify = python_39 and conf.get('HAVE_GNU_EFI') == 1
-elif get_option('ukify') == 'true' and (not python_39 or conf.get('HAVE_GNU_EFI') != 1)
- error('ukify requires Python >= 3.9 and GNU EFI')
-else
- want_ukify = get_option('ukify') == 'true'
-endif
-
-############################################################
-
# binaries that have --help and are intended for use by humans,
# usually, but not always, installed in /bin.
public_programs = []