summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 97246a3c6f..d1e39c8a5a 100644
--- a/meson.build
+++ b/meson.build
@@ -354,6 +354,8 @@ basic_disabled_warnings = [
]
possible_common_cc_flags = [
+ '-Warray-bounds', # clang
+ '-Warray-bounds=2',
'-Wdate-time',
'-Wendif-labels',
'-Werror=format=2',
@@ -391,6 +393,8 @@ possible_common_cc_flags = [
# negative arguments are correctly detected starting with meson 0.46.
'-Wno-error=#warnings', # clang
'-Wno-string-plus-int', # clang
+
+ '-fstrict-flex-arrays',
]
c_args = get_option('c_args')