summaryrefslogtreecommitdiff
path: root/src/boot/efi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/boot/efi/meson.build')
-rw-r--r--src/boot/efi/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/boot/efi/meson.build b/src/boot/efi/meson.build
index 7e497f7866..bfc3f9c279 100644
--- a/src/boot/efi/meson.build
+++ b/src/boot/efi/meson.build
@@ -139,6 +139,7 @@ efi_c_args += cc.get_supported_arguments(
'-fwide-exec-charset=UCS2',
# gcc docs says this is required for ms_abi to work correctly.
'-maccumulate-outgoing-args',
+ '-mstack-protector-guard=global',
)
# Debug information has little value in release builds as no normal human being knows
@@ -180,8 +181,6 @@ efi_disabled_c_args = cc.get_supported_arguments(
'-fno-exceptions',
'-fno-trapv',
'-fno-sanitize=all',
- '-fno-stack-clash-protection',
- '-fno-stack-protector',
'-fno-unwind-tables',
)
efi_c_args += efi_disabled_c_args