summaryrefslogtreecommitdiff
path: root/src/cryptenroll/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/cryptenroll/meson.build')
-rw-r--r--src/cryptenroll/meson.build9
1 files changed, 1 insertions, 8 deletions
diff --git a/src/cryptenroll/meson.build b/src/cryptenroll/meson.build
index 0a795934e2..9080af0db9 100644
--- a/src/cryptenroll/meson.build
+++ b/src/cryptenroll/meson.build
@@ -1,19 +1,12 @@
# SPDX-License-Identifier: LGPL-2.1-or-later
systemd_cryptenroll_sources = files(
- 'cryptenroll-fido2.h',
'cryptenroll-list.c',
- 'cryptenroll-list.h',
'cryptenroll-password.c',
- 'cryptenroll-password.h',
- 'cryptenroll-pkcs11.h',
'cryptenroll-recovery.c',
- 'cryptenroll-recovery.h',
- 'cryptenroll-tpm2.h',
'cryptenroll-wipe.c',
- 'cryptenroll-wipe.h',
'cryptenroll.c',
- 'cryptenroll.h')
+)
if conf.get('HAVE_P11KIT') == 1 and conf.get('HAVE_OPENSSL') == 1
systemd_cryptenroll_sources += files('cryptenroll-pkcs11.c')