summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2004-01-21 10:31:06 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2004-01-21 10:31:06 +0000
commit143e677b5e8f5167ab8b7d711192f7558a4129b6 (patch)
treeaf75f985f0afd4c4762cf74139e60dc9b841eb3f /Makefile.am
parent092b81cb95eaafeb1869509e03a664bebf507604 (diff)
downloadtar-143e677b5e8f5167ab8b7d711192f7558a4129b6.tar.gz
Removed m4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am71
1 files changed, 17 insertions, 54 deletions
diff --git a/Makefile.am b/Makefile.am
index ba7245fb..be480831 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,60 +1,23 @@
# Main Makefile for GNU tar.
-# Copyright (C) 1994, 1995, 1996, 1997 Free Software Foundation, Inc.
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
-# any later version.
+# Copyright (C) 1994, 1995, 1996, 1997, 1999, 2000, 2001, 2003 Free
+# Software Foundation, Inc.
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-# 02111-1307, USA.
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
-AUTOMAKE_OPTIONS = gnits dist-shar
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+## 02111-1307, USA.
-BABYL = rmail/* admin/*/RMAIL
-EXTRA_DIST = AC-PATCHES AM-PATCHES BI-PATCHES PORTS rebox.el
-SUBDIRS = doc lib intl src scripts po tests
-
-all-local: $(CONFIG_HEADER)
-
-id: ID
-
-ID:
- cd lib && $(MAKE) $@
- cd src && $(MAKE) $@
-
-dist-zoo: $(DISTFILES)
- rm -rf $(distdir)
- mkdir $(distdir)
- distdir=`cd $(distdir) && pwd` \
- && cd $(srcdir) \
- && automake --include-deps --output-dir=$$distdir
- @for file in $(DISTFILES); do \
- test -f $(distdir)/$$file \
- || cp -p $(srcdir)/$$file $(distdir)/$$file; \
- done
- for subdir in $(SUBDIRS); do \
- test -d $(distdir)/$$subdir \
- || mkdir $(distdir)/$$subdir \
- || exit 1; \
- chmod 777 $(distdir)/$$subdir; \
- (cd $$subdir && $(MAKE) dist) || exit 1; \
- done
- @sublist="$(DIST_SUBDIRS)"; \
- for dir in $$sublist; do \
- echo copying directory $$dir; \
- tar -chf - $$dir | (cd $(distdir) && tar -xBpf -); \
- done
- chmod -R a+r $(distdir)
- find $(distdir) -type f | xargs dosfn
-# find $(distdir) -type f | xargs recode :ibmpc
- mv $(distdir) $(PACKAGE)
- find $(PACKAGE) -type f | zoo ahIq $(PACKAGE).zoo
- rm -rf $(PACKAGE)
+ACLOCAL_AMFLAGS = -I m4
+EXTRA_DIST = ChangeLog.1 PORTS
+SUBDIRS = doc lib src scripts po tests