summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2013-10-23 18:38:34 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2013-10-23 18:38:56 -0700
commit00054440c7374fcd0106eb9b441c5972975a01d8 (patch)
tree6bd327c9e1ea359292a3dea0e29522b7193092af /configure.ac
parenta2e0cd0c0593b7084fbe47d46ddab945cd24af02 (diff)
downloadtar-00054440c7374fcd0106eb9b441c5972975a01d8.tar.gz
build: fix bug where 'configure --with-posix-acls' disables ACLs
Reported by Lars Wendler in <http://lists.gnu.org/archive/html/bug-tar/2013-10/msg00022.html>. * configure.ac (with_posix_acls): Fix typo.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3bff70ed..e572b774 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,7 +74,8 @@ fi
AC_ARG_WITH([posix-acls],
AS_HELP_STRING([--without-posix-acls],
[do not use POSIX.1e access control lists]),
- [with_posix_acls=no])
+ [],
+ [with_posix_acls=yes])
if test "x$with_posix_acls" != "xno"; then
AC_CHECK_HEADERS(sys/acl.h,, [with_posix_acls=no])
for tar_acl_func in acl_get_file acl_get_fd acl_set_file acl_set_fd \