summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2010-09-14 13:33:21 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2010-09-14 13:34:25 -0700
commit59146768ef4a2c045239628b7179ea477563d63f (patch)
treee1a18bb7d3da48ece303d3ce0d54241ad43e4e1a /configure.ac
parent0fb3020da0b2c3c6a15b3785f3900cbcf444c2ff (diff)
downloadtar-59146768ef4a2c045239628b7179ea477563d63f.tar.gz
* configure.ac: tar: close some race conditions when extracting
* configure.ac: Check for fchmod and fchown. Don't check for utimes. * src/extract.c (fdchmod, fdchown, fdstat): New functions. (set_mode, set_stat): New arg FD. All callers changed. This avoids some race conditions between closing a regular file and setting its metadata, and it's a bit faster.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e84a8391..62df25fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,7 +90,7 @@ gl_INIT
# paxutils modules
tar_PAXUTILS
-AC_CHECK_FUNCS(fsync getdtablesize lstat mkfifo readlink symlink setlocale utimes)
+AC_CHECK_FUNCS(fchmod fchown fsync getdtablesize lstat mkfifo readlink symlink setlocale)
AC_CHECK_DECLS([getgrgid],,, [#include <grp.h>])
AC_CHECK_DECLS([getpwuid],,, [#include <pwd.h>])
AC_CHECK_DECLS([time],,, [#include <time.h>])