summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancois-Xavier Le Bail <devel.fx.lebail@orange.fr>2020-05-29 23:37:36 +0200
committerFrancois-Xavier Le Bail <devel.fx.lebail@orange.fr>2020-05-30 00:05:22 +0200
commit0181656313fbe514928263f4061d42d338a5bb7c (patch)
tree104f6bbd2bf03175f5fcc015f26fe3dc8b7072e5 /CMakeLists.txt
parent65a0c47dc8103f3794e07dc35bd72b52a67a76c7 (diff)
downloadtcpdump-0181656313fbe514928263f4061d42d338a5bb7c.tar.gz
Compile with '-Wmissing-variable-declarations' if it's available
(In devel mode)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab16f52c..b2894b1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -891,6 +891,7 @@ if(EXISTS ${CMAKE_SOURCE_DIR}/.devel OR EXISTS ${CMAKE_BINARY_DIR}/.devel)
check_and_add_compiler_option(-Wassign-enum)
check_and_add_compiler_option(-Wcast-qual)
check_and_add_compiler_option(-Wmissing-prototypes)
+ check_and_add_compiler_option(-Wmissing-variable-declarations)
check_and_add_compiler_option(-Wold-style-definition)
check_and_add_compiler_option(-Wpedantic)
check_and_add_compiler_option(-Wpointer-arith)