summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDenis Ovsienko <denis@ovsienko.info>2018-07-28 20:07:13 +0100
committerDenis Ovsienko <denis@ovsienko.info>2018-07-28 20:48:16 +0100
commit9b1c2ba51b6dbc57af17c8c054ff8b55486d674c (patch)
tree7edfa70b627b694e2594495954496d933220517d /configure.ac
parent40e217a816cee20d4aa92f5d06d7ad5d4acc4050 (diff)
downloadtcpdump-9b1c2ba51b6dbc57af17c8c054ff8b55486d674c.tar.gz
Try the pcap_dump_ftell() check after pcap-config.
Apparently, the test for pcap_dump_ftell() cannot succeed if the test program isn't linked with libpcap, this depending on the output of pcap-config. That's why all pcap_* function checks come after the pcap-config check. This explains why in my working copy a ./configure build of the previous commit tree with the master branch of libpcap found that the function was "missing" and tried to substitute it with the local implementation and eventually failed trying to link with libpcap that actually had the function. However, this does not explain why all 32 Travis CI builds of the same tree passed, including the builds that used autotools.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5a253743..bdcb9e74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -409,7 +409,7 @@ AC_INCLUDES_DEFAULT
fi
])
-AC_REPLACE_FUNCS(strlcat strlcpy strdup strsep getservent getopt_long pcap_dump_ftell)
+AC_REPLACE_FUNCS(strlcat strlcpy strdup strsep getservent getopt_long)
AC_CHECK_FUNCS(fork vfork strftime)
AC_CHECK_FUNCS(setlinebuf)
@@ -726,6 +726,7 @@ if test $ac_cv_func_pcap_lib_version = "no" ; then
fi
AC_CHECK_FUNCS(pcap_setdirection pcap_set_immediate_mode pcap_dump_ftell64)
AC_CHECK_FUNCS(pcap_open pcap_findalldevs_ex)
+AC_REPLACE_FUNCS(pcap_dump_ftell)
#
# Check for special debugging functions