summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMingrui <972931182@qq.com>2021-11-04 09:07:23 +0800
committerMingrui <972931182@qq.com>2021-11-04 09:07:23 +0800
commitcb0099044b507aa6a537443ab79384e2ea5bdc94 (patch)
tree1aadfa95231ba712eb3d4116e4a2470acca93d85 /configure.ac
parentd3eb92550ac24e4fce8bea3b8ea47d2bef08dbda (diff)
downloadtcpdump-cb0099044b507aa6a537443ab79384e2ea5bdc94.tar.gz
[bugfix]configure: fix error when cross-compile
While cross-compile, ./configure --host=xxx will output: "checking whether printf(3) supports the z length modifier... configure: error: in `/${path_to_tcpdump}/tcpdump':" That is casued by AC_RUN_IFELSE, as describe in "https://www.gnu.org/software/autoconf/manual/autoconf-2.63/html_node/Runtime.html" , if AC_RUN_IFELSE do not have cross-compile option, configure prints an error message and exits. Signed-off-by: Mingrui Ren jiladahe1997@gmail.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e6e47e1..12d81294 100644
--- a/configure.ac
+++ b/configure.ac
@@ -423,6 +423,9 @@ int main()
AC_MSG_RESULT(no)
AC_DEFINE(HAVE_NO_PRINTF_Z, 1,
[Define to 1 if printf(3) does not support the z length modifier.])
+ ],
+ [
+ AC_MSG_RESULT(not while cross-compiling)
]
)