summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorguy <guy>2004-08-27 07:17:03 +0000
committerguy <guy>2004-08-27 07:17:03 +0000
commit0b18136512b0ec413821e5210ab5f343f622ee98 (patch)
treeb53d1d848e3b9253e0ba40167f8741bc966106e8 /configure.in
parent99711cd61e54afc6c20c544eaad5b13c1c2338f0 (diff)
downloadtcpdump-0b18136512b0ec413821e5210ab5f343f622ee98.tar.gz
From Andrew Church <andrew@users.sourceforge.net>: when testing for
"pcap_version", "pcap_debug", and "yydebug", don't add our own functions referring to those variables - GCC 3.4.1 optimizes the test code out before the link is done, as it's in a function that's not called.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 3 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 35622152..b9d942fa 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-dnl @(#) $Header: /tcpdump/master/tcpdump/configure.in,v 1.181 2004-07-10 21:53:31 guy Exp $ (LBL)
+dnl @(#) $Header: /tcpdump/master/tcpdump/configure.in,v 1.182 2004-08-27 07:17:04 guy Exp $ (LBL)
dnl
dnl Copyright (c) 1994, 1995, 1996, 1997
dnl The Regents of the University of California. All rights reserved.
@@ -6,7 +6,7 @@ dnl
dnl Process this file with autoconf to produce a configure script.
dnl
-AC_REVISION($Revision: 1.181 $)
+AC_REVISION($Revision: 1.182 $)
AC_PREREQ(2.50)
AC_INIT(tcpdump.c)
@@ -602,13 +602,9 @@ if test $ac_cv_func_pcap_lib_version = "no" ; then
AC_MSG_CHECKING(whether pcap_version is defined by libpcap)
AC_TRY_LINK([],
[
-char *
-return_pcap_version(void)
-{
extern char pcap_version[];
- return pcap_version;
-}
+ return (int)pcap_version;
],
ac_lbl_cv_pcap_version_defined=yes,
ac_lbl_cv_pcap_version_defined=no)
@@ -622,13 +618,9 @@ fi
AC_MSG_CHECKING(whether pcap_debug is defined by libpcap)
AC_TRY_LINK([],
[
-int
-return_pcap_debug(void)
-{
extern int pcap_debug;
return pcap_debug;
-}
],
ac_lbl_cv_pcap_debug_defined=yes,
ac_lbl_cv_pcap_debug_defined=no)
@@ -643,13 +635,9 @@ else
AC_MSG_CHECKING(whether yydebug is defined by libpcap)
AC_TRY_LINK([],
[
- int
- return_yydebug(void)
- {
extern int yydebug;
return yydebug;
- }
],
ac_lbl_cv_yydebug_defined=yes,
ac_lbl_cv_yydebug_defined=no)