summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorguy <guy>2003-12-15 02:12:40 +0000
committerguy <guy>2003-12-15 02:12:40 +0000
commitdef086699439820ec021f77300cc6eaa516e64b3 (patch)
treefbf8453a1659817bef9070c2d0f69a00759611e3 /configure.in
parentb8c884ee9ce7e63e8bf678fdb38eabcf086e9b2a (diff)
downloadtcpdump-def086699439820ec021f77300cc6eaa516e64b3.tar.gz
From Albert Chin <china@thewrittenword.com>:
propagate CPPFLAGS to Makefile.in; move the CPPFLAGS and V_INCLS change to the end of the configure run so users don't see "-I$(srcdir)/missing" in their config.log output.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 99b3e525..88ce5e14 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-dnl @(#) $Header: /tcpdump/master/tcpdump/configure.in,v 1.170 2003-11-16 09:36:09 guy Exp $ (LBL)
+dnl @(#) $Header: /tcpdump/master/tcpdump/configure.in,v 1.171 2003-12-15 02:12:40 guy Exp $ (LBL)
dnl
dnl Copyright (c) 1994, 1995, 1996, 1997
dnl The Regents of the University of California. All rights reserved.
@@ -6,7 +6,7 @@ dnl
dnl Process this file with autoconf to produce a configure script.
dnl
-AC_REVISION($Revision: 1.170 $)
+AC_REVISION($Revision: 1.171 $)
AC_PREREQ(2.13)
AC_INIT(tcpdump.c)
@@ -471,13 +471,6 @@ dnl
dnl Checks if res_state structure has nsort member.
AC_STRUCT_RES_STATE(ac_cv_res_state)
-dnl
-dnl set additional include path if necessary
-if test "$missing_includes" = "yes"; then
- CPPFLAGS="$CPPFLAGS -I\$(srcdir)/missing"
- V_INCLS="$V_INCLS -I\$(srcdir)/missing"
-fi
-
AC_REPLACE_FUNCS(vfprintf strcasecmp strlcat strlcpy strdup strsep)
AC_CHECK_FUNCS(strftime)
@@ -731,6 +724,13 @@ if test "$ac_cv_ssleay_path" != no; then
fi
])
+dnl
+dnl set additional include path if necessary
+if test "$missing_includes" = "yes"; then
+ CPPFLAGS="$CPPFLAGS -I\$(srcdir)/missing"
+ V_INCLS="$V_INCLS -I\$(srcdir)/missing"
+fi
+
AC_SUBST(V_CCOPT)
AC_SUBST(V_DEFS)
AC_SUBST(V_GROUP)