summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 677d219..afe76d5 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -11,7 +11,12 @@ all-local: $(SEQ_DIA_PNGS)
# pic2plot wants sequence.pic in the build dir, so use a hack - copy it in
%.png: %.pic sequence.pic
- cp $(srcdir)/sequence.pic .
+ if ! test -e sequence.pic; then \
+ touch copied-sequence-pic && \
+ cp $(srcdir)/sequence.pic .; \
+ fi
set -o pipefail; $(PIC2PLOT) -Tps --font-name AvantGarde-Book $< | $(CONVERT) -density 112 - $@ ; rm .sequence.temp
- rm -f sequence.pic
+ if test -e copied-sequence-pic; then \
+ rm -f copied-sequence-pic sequence.pic; \
+ fi
endif