summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2007-04-19 17:35:17 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2007-04-19 17:35:17 +0000
commit05b3d77a6ceaf9142e0dee8bf52e7637d5823bdd (patch)
treeae7da2dc08fb4c3aa1c6b09ffa1c57d2d3adf24a /Makefile.am
parent90720ee40eb30e2b1c9aa90501391d3a0a411250 (diff)
downloadtelepathy-glib-05b3d77a6ceaf9142e0dee8bf52e7637d5823bdd.tar.gz
Move contents of lib/ into root directory
20070419173517-53eee-d91a15d77882d6839193c1f77be4f88803b48f58.gz
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2dc007505..e60b9fcee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,11 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = lib m4
+SUBDIRS = m4 tools spec telepathy-glib tests docs
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --disable-debug
+
+pkgconfigdir = ${libdir}/pkgconfig
+pkgconfig_DATA = telepathy-glib.pc telepathy-glib-unstable.pc
EXTRA_DIST = \
check-coding-style.mk \
@@ -8,7 +13,11 @@ EXTRA_DIST = \
check-whitespace.sh \
gtk-doc.make
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --disable-debug
+CLEANFILES = FIXME.out
+
+check-local::
+ egrep -A 5 '[F]IXME|[T]ODO|[X]XX' $(srcdir)/telepathy-glib/*.[ch] \
+ > FIXME.out || true
dist-hook:
chmod u+w ${distdir}/ChangeLog