summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2009-10-01 14:30:34 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2009-12-03 14:48:41 +0000
commit07b03e187fb711f6006c7dbe0341ed0e6890153c (patch)
treed46718d5e98d6c081569cc7e6ce50c33cda71839 /Makefile.am
parent1d22bde3ee935189fcb322415d16ffd86d63214a (diff)
downloadtelepathy-glib-07b03e187fb711f6006c7dbe0341ed0e6890153c.tar.gz
Add a top-level target to run valgrind, and make it log the output
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fd871bb8f..5d2f60655 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,6 +14,9 @@ check-local::
egrep -A 5 '[F]IXME|[T]ODO|[X]XX' $(srcdir)/telepathy-glib/*.[ch] \
> FIXME.out || true
+check-valgrind:
+ $(MAKE) -C tests check-valgrind 2>&1 | tee valgrind.log
+
maintainer-upload-release: _maintainer-upload-release-local
_maintainer-upload-release-local: _maintainer-upload-release-check
rsync -rvzPp --chmod=Dg+s,ug+rwX,o=rX docs/reference/html/ \