summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2008-10-22 10:39:21 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2008-10-22 10:39:21 +0100
commit3110d3e7da4cb0cab0d3bb1e05d74996952d3a6e (patch)
tree80d5f91e1636bfdf9a30797a94c4647f5789df9e /Makefile.am
parentc344ad514f338a3e20c8bdd0a6a85dd1c6dd58fb (diff)
downloadtelepathy-glib-3110d3e7da4cb0cab0d3bb1e05d74996952d3a6e.tar.gz
Makefile.am: add upload-branch-docs target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 352bafca8..a86c664c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,5 +19,12 @@ _maintainer-upload-release-local: _maintainer-upload-release-check
rsync -rtvzPp --chmod=Dg+s,ug+rwX,o=rX docs/reference/html/ \
telepathy.freedesktop.org:/srv/telepathy.freedesktop.org/www/doc/telepathy-glib/
+BRANCH = misc
+UPLOAD_BRANCH_TO = people.freedesktop.org:public_html/telepathy-glib
+
+upload-branch-docs: all
+ rsync -rtzvPp --chmod=a+rX docs/reference/html/ \
+ $(UPLOAD_BRANCH_TO)-$(BRANCH)/
+
include tools/lcov.am
include tools/telepathy.am