summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-05-02 12:15:26 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-05-02 12:15:26 +0100
commit58b6f88c53bb68d468f4cbdfdf25bb750300387f (patch)
tree911a3dd844998efc5dd288089795daf2ecc4da9d /Makefile.am
parentdf950691ff246bf556a1ee5ff59fdaac0f191437 (diff)
parentf3681d4dddcfbb86525dcf2b9371231ad3681de5 (diff)
downloadtelepathy-glib-58b6f88c53bb68d468f4cbdfdf25bb750300387f.tar.gz
Merge branch 'telepathy-glib-0.18'
Conflicts: NEWS
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1948f352a..3e5e58aaa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,3 +52,16 @@ CHANGELOG_RANGE = telepathy-glib-0.14.0..
CHECK_FOR_UNRELEASED = $(srcdir)/NEWS $(wildcard $(srcdir)/telepathy-glib/*.[ch])
include tools/telepathy.am
+
+# Don't just "make distclean", because that would result in forgetting
+# the options we used when we ran configure.
+#
+# However, we do want to distclean in docs (to get rid of xml, html etc.)
+# and in telepathy-glib (to get rid of any stray files in _gen which might
+# not exist on the new branch).
+clean-for-new-branch:
+ $(MAKE) clean
+ $(MAKE) -C docs distclean
+ $(MAKE) -C telepathy-glib distclean
+ $(SHELL) ./config.status --recheck
+ $(SHELL) ./config.status