summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-05-01 13:14:04 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-05-02 12:07:20 +0100
commit759d4b5ff49e1f067ef6cf3cc71e2584d1067ed6 (patch)
treeab89ba3d1252d3a5da6511570039a8c17b5fdbc6 /Makefile.am
parent5d2f1f6a6b491a9eb05ff0013a258471d59248de (diff)
downloadtelepathy-glib-759d4b5ff49e1f067ef6cf3cc71e2584d1067ed6.tar.gz
Add `make clean-for-new-branch`
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 30bfbb129..be257aa69 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,3 +52,16 @@ CHANGELOG_RANGE = telepathy-glib-0.14.0..
CHECK_FOR_UNRELEASED = $(srcdir)/NEWS $(wildcard $(srcdir)/telepathy-glib/*.[ch])
include tools/telepathy.am
+
+# Don't just "make distclean", because that would result in forgetting
+# the options we used when we ran configure.
+#
+# However, we do want to distclean in docs (to get rid of xml, html etc.)
+# and in telepathy-glib (to get rid of any stray files in _gen which might
+# not exist on the new branch).
+clean-for-new-branch:
+ $(MAKE) clean
+ $(MAKE) -C docs distclean
+ $(MAKE) -C telepathy-glib distclean
+ $(SHELL) ./config.status --recheck
+ $(SHELL) ./config.status