summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2010-08-17 11:51:53 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2010-08-17 11:51:53 +0100
commite7df0c7ad266dbd993a3814470a334cee023ab26 (patch)
tree00d8528e719d709fd08eeddadf522948ebc12da3 /Makefile.am
parent80c0a6edfd19b58666136e159b83c6ffc9152aae (diff)
downloadtelepathy-glib-e7df0c7ad266dbd993a3814470a334cee023ab26.tar.gz
Makefile.am, configure.ac: refuse to make dist if automake is too old
This avoids accidentally making tarballs that can't have vala bindings.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2083cfe0a..6237ff2db 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,6 +45,17 @@ upload-branch-docs: all
rsync -rtzvPp --chmod=a+rX docs/reference/html/ \
$(UPLOAD_BRANCH_TO)-$(BRANCH)/
+if HAVE_AUTOMAKE_FOR_DIST
+# automake is new enough to make dist
+else
+dist-hook: dist-hook-check-am
+dist-hook-check-am:
+ @echo "*** Your automake is too old to compile Vala.">&2
+ @echo "*** You can build telepathy-glib with this automake, but you">&2
+ @echo "*** should not use it to make tarball releases.">&2
+ @exit 1
+endif
+
include tools/lcov.am
CHANGELOG_RANGE = telepathy-glib-0.8.0..