summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-03-07 12:59:56 +0100
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-03-07 13:40:04 +0100
commitebd37e9690a542574ef93df7eb775eeb27ddd68d (patch)
tree59610633603bf9f5dd6c53141418c39f13df7d46 /configure.ac
parentc1da88f54b7444fe406d72c85f7d7291a2a2451d (diff)
downloadtelepathy-glib-ebd37e9690a542574ef93df7eb775eeb27ddd68d.tar.gz
Make use of new GLib macros to check API we are using
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 79f286dbc..e03d1494f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,10 +68,6 @@ AC_SUBST([LT_CURRENT])
AC_SUBST([LT_REVISION])
AC_SUBST([LT_AGE])
-# Disable GLib deprecation warnings for now; GValueArray is deprecated but we
-# need it for dbus-glib.
-AC_DEFINE(GLIB_DISABLE_DEPRECATION_WARNINGS, 1, [Build with GLib deprecated])
-
dnl optimizations, etc.
COMPILER_OPTIMISATIONS
COMPILER_COVERAGE
@@ -203,6 +199,9 @@ dnl Check for Glib
PKG_CHECK_MODULES(GLIB,
[glib-2.0 >= 2.30.0, gobject-2.0 >= 2.30.0, gio-2.0 >= 2.30.0])
+AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_30], [Ignore post 2.30 deprecations])
+AC_DEFINE([GLIB_VERSION_MAX_REQUIRED], [GLIB_VERSION_2_30], [Prevent post 2.30 APIs])
+
dnl Check for GIO-Unix
PKG_CHECK_MODULES(GIO_UNIX, [gio-unix-2.0],
have_gio_unix=yes, have_gio_unix=no)